Jump to content


SINCE 1996
Proudly partnered with TheTerraceStore.com

[Archived] Help - new USB stick won't work

Recommended Posts

So I bought a shiny new USB stick to help me transfer stuff for a new job that I've bagged. I insert it into my PC, it says, 'You need to format the disk in E drive before you can use it.' Then it asks me if I want to format it, I click yes (Format disk) and it tells me, 'Windows can't format E. Check to see that the disk is not read-only, and then try again...'

Please can anyone help as I haven't a scooby what to do with this and I need to get my files shifted pronto?

Thanks, Dawn

Link to comment
Share on other sites

In my experience a new USB stick shouldn't need formatting.

Try a different USB port. What message do you get first?

Can you see the stick in Windows Explorer? If you right click on the drive what options do you get? Can you reformat from one of those options?

I usually find a bit of googling helps in these situations.

Link to comment
Share on other sites

Tried lots of different ports. Tried lots of ways of formatting and nothing worked so sacked it off as a bad job. I acutally bought two of the buggers and have just put the other one in and guess what? That begger works fine. So I've wasted my and your time on a ruddy faulty stick. Magic. Sorry and thanks anyway, Stuart.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.